Troubleshooting SharePoint email alerts – Checking the Email Infrastructure

November 27th, 2009 by Ryan

This part of the alert troubleshooting guide will talk you through the steps necessary to verify that emails can be successfully routed from your SharePoint server to the users mailbox.

You should have first read the introduction so you know the difference between the confirmation Emails and Alert emails and understand why :-

  • Even if you get one of those you may still need to verify how your email setup is configured.
  • You need to check each WFE and your index server

You may also want to read this short SMTP primer if you are new to SMTP and related email technologies.

Sending test emails

First check the email settings in SharePoint central administration are correct (SharePoint Central Administration > Operations > Outgoing Emails Settings) – note the Outbound SMTP server, From and Reply To addresses.

Use these settings to send some test emails using a tool like the SMTP Test Tool or Telnet on your SharePoint servers to send some test emails.

If you don’t receive the emails you expect verify.

  • Does the SMTP server permit connections (relay’s) from your SharePoint servers?
  • Is the destination SMTP server configured to deliver emails or relay them to another SMTP server and if so is it working?
  • Is there anything that may block SMTP transmissions on port 25 (common to stop mass mailing worms/viruses). For example :-
    • A firewall running on or in between the SharePoint server and the SMTP server
    • Antivirus software
    • Remember that if your security blocks SMTP transmissions based on process or account then test tools such as Telnet or SMTP Test tool will be a different process and will often be running under a different account to SharePoint and the timer service.

If you do get the emails you expect from these test tools

  • Verify that you haven’t got any anti-virus or other security in place that could allow these test messages through but still block the ones from SharePoint – see “Is there anything that may block SMTP transmissions…” above
  • Go back to the flowchart and continue onto the next step

You are able to send test emails to some users, but not others

(Note – this section does not apply to emails sent by SharePoint but only to test emails sent using a tool like SMTP Test tool or telnet – see above)

The good news is that you know in this case that its not a problem with SharePoint – its time to bring in whomever is an expert on your email infrastructure but a few tips to get you started :-

  • Is this user’s email is being delivered successfully from other sources, what about external email addresses such as hotmail / gmail?
    • This can help narrow down the problem between problems on the sending side an receiving side.
  • Do emails to users on the internal domain get delivered and external email addresses fail (or vice versa) – in which case you need to look in detail at your email infrastructure to determine where the problem lies. 

As always the wildcards are SPAM filters and email auto processing rules – always suspect these first!

Tags: , ,
Posted in Troubleshooting Alerts | 7 Comments »

7 Responses to “Troubleshooting SharePoint email alerts – Checking the Email Infrastructure”

  1. vel says:

    Hi,my sharepoint server alert notification mail is working initially.after installing service pack 2 of sharepoint server alert mail is not working.what is the issue.please help me,Vel

  2. Ryan says:

    @Vel – There are dozens of reasons why this might be – thats what the troubleshooting guide is for. Have you been through the different steps?

  3. Joseph says:

    I wish Microsoft would do something like this — it would make troubleshooting much more quick and painless…

  4. … track backe bei ……

    très bon , votre weblog thème est certainement merveilleux , je suis recherche pour un nouveau design pour mon moncler doudoune propre personnel blog , j’aime vôtre, maintenant Je vais à aller cherchez le exacte même modèle !…

  5. Kshitiz says:

    Hi Ryan,

    I am facing an issue with workflow emails ,

    The users to which the workflow is assigned don’t receive the mails but those marked in cc receive it.
    When the same users are (which were earlier marked in “To”) were mentioned in cc (i.e. Notify others section), they received the mails.

  6. Ryan says:

    @Kshitiz – Hmm, my first thought is that they are getting caught in a SPAM filter. Have you ruled that out?

  7. Kshitiz says:

    Yes Ryan.

Leave a Reply

Anti-Spam Quiz: